Loud V10

Discussion in 'Tow Rigs and Trailers' started by awa0728, Jan 17, 2006.

  1. awa0728

    awa0728 New Member

    Joined:
    Apr 14, 2005
    Location:
    Charlotte, NC
    I bought a 2002 Ford Excursion V10 in December. I notice that from about 72-78 MPH it makes a LOT of noise. It quiet backs down about 80 MPH. 75 mph is the worse, it also vibrates a bit. Any idea what it might be? It gets real loud like a roar...can;t tell if its the tires or what? Ideas???

    Thanks
     
  2. crawlinjp

    crawlinjp Well-Known Member

    Joined:
    Mar 20, 2005
    Location:
    Cary
    Best bet is to check some excursion forums and see what they have to say. It could be anything. The 03 Dodges had a drone btw 70-75 and they figured out it was a power steering hose. So Dodge came out with a weighted ps hose and no more drone.
     
  3. spraypaintman

    spraypaintman Well-Known Member

    Joined:
    Mar 21, 2005
    Location:
    Greensboro
    Mine vibrates, I believe it's the tires. I know one of my fronts needs to be balanced or maybe I need an alignment. Not sure about the roar you are hearing.
     
  4. awa0728

    awa0728 New Member

    Joined:
    Apr 14, 2005
    Location:
    Charlotte, NC
    The load roar and vibration turned into a new transfer case for the Excursion.

    I took it over to Andy at CRS today for him to look at it and see if the driveshaft maybe needed balancing, well after he took it for a spin up to the drivetrain shop, he called me to tell me it was really sick, leaking fluid, CV joints bad, yoke loose and other things not right.

    So its getting a transfer case put in, new joints and whatever else it takes...

    I am just glad it didn't happen on the road with 6000lbs of Jeep behind me.

    Thanks Andy!
     

Share This Page