What have you done to your rig today?

BIGWOODY

Well-Known Member
Joined
Mar 21, 2005
Location
Thomasville
Got her on the lift and ready to start the rehab. Started a drivetrain swap almost 10 years ago and never finished. My daughter just talked me into finishing it.
IMG_20220417_204213654.jpg
IMG_20220417_204200596.jpg
 

BigSouth

Doesn't play well with others!
Joined
Jun 8, 2011
Location
Shelby, NC
Me and the boy decided to ditch the stock rails and upgrade to some Metal Cloak rocker armor. Jury is still out on reinstalling the rails. They’ll need blast and powder if we do. Kinda crusty. We opted for satin paint to give it that subtle difference from the gloss black body.
4CD7D45F-1EA6-4EDA-8C26-C0BC6B63E634.jpeg
 

KrawlerTJ

Well-Known Member
Joined
Mar 21, 2005
Location
Mooresville NC
Got the rear motobilt frame chop bumper installed and also finished up the steering with new PSC pump, reservoir, ram, and new cooler. Turns the 37’s great now
 

Attachments

  • 0ECC19A8-32C1-4C21-9F71-ADDAE9D4CC1B.jpeg
    0ECC19A8-32C1-4C21-9F71-ADDAE9D4CC1B.jpeg
    183 KB · Views: 37
  • AE3E274A-2210-4D84-A574-D9A96492CE38.jpeg
    AE3E274A-2210-4D84-A574-D9A96492CE38.jpeg
    108.2 KB · Views: 39
  • 5313CA40-3752-46A3-9FD9-28F0337474C7.jpeg
    5313CA40-3752-46A3-9FD9-28F0337474C7.jpeg
    150.8 KB · Views: 37
  • B911BDDF-E33F-4369-ACEF-F03B182D2DBE.jpeg
    B911BDDF-E33F-4369-ACEF-F03B182D2DBE.jpeg
    171.3 KB · Views: 37

CLRracer

Mopar Nut
Joined
Mar 20, 2005
Location
Archer Lodge
Despite several times draining the water, drying it out, adjusting the vents, etc, the passenger headlight on my truck kept getting condensation (to put it mildly) in it. Well a month or two ago I got a message on the dash of a turn signal being out and the super fast flash. The turn signals were still working, except for one led bulb in the turn signal strip. Still functional, but super annoying, and also not replaceable. So finally got around to ordering new assemblies and installed them today.

20220428_165942.jpg

20220428_165951.jpg


Duane
 

ShimShim

Well-Known Member
Joined
Apr 21, 2005
Location
Charlotte, NC
Despite several times draining the water, drying it out, adjusting the vents, etc, the passenger headlight on my truck kept getting condensation (to put it mildly) in it. Well a month or two ago I got a message on the dash of a turn signal being out and the super fast flash. The turn signals were still working, except for one led bulb in the turn signal strip. Still functional, but super annoying, and also not replaceable. So finally got around to ordering new assemblies and installed them today.

View attachment 371719
View attachment 371718

Duane
My ram does the same thing with the turn signal out. Suuuuuper annoying when only one or two LED bulbs is out and you get the fast flash and message all the time. Luckily I've never had to deal with the condensation in the headlights.
 

CLRracer

Mopar Nut
Joined
Mar 20, 2005
Location
Archer Lodge
Yeah I dealt with the condensation for years, and probably would have dealt with the fast flash and message for longer if I didn't have the condensation. But since I had both, I spent a little money and replaced them. I was trying to find some OEM takeoffs from some bro dozer that upgraded to the 1400 dollar morimoto headlights, but I guess everyone was trying to make that sting hurt a little less by asking crazy money for them, so aftermarket it is.

Duane
 

paradisePWoffrd

Recovering Project Junkie
Joined
Nov 5, 2005
Location
Newton, NC
My ram does the same thing with the turn signal out. Suuuuuper annoying when only one or two LED bulbs is out and you get the fast flash and message all the time. Luckily I've never had to deal with the condensation in the headlights.

There is probly a resistor one could put in line to prevent the flash
 

tlucier

Well-Known Member
Joined
Jun 3, 2007
Location
Mebane, NC
Despite several times draining the water, drying it out, adjusting the vents, etc, the passenger headlight on my truck kept getting condensation (to put it mildly) in it. Well a month or two ago I got a message on the dash of a turn signal being out and the super fast flash. The turn signals were still working, except for one led bulb in the turn signal strip. Still functional, but super annoying, and also not replaceable. So finally got around to ordering new assemblies and installed them today.

View attachment 371719
View attachment 371718

Duane
I had the same problem in the passenger side of my 2014, 2500. There was so much water in there it looked like a fishbowl. The led light on the bottom was under water, and the water level was almost up to the headlight. I think I replaced it 3 to 4 years ago and never had a problem. I probably just jinxed myself.
 

willness33

Here for the memes
Joined
May 3, 2005
Location
Alexis,NC
Installed a jeepair ac kit into the kids TJ that did not have it from the factory. Seems to be holding vacuum so far. I just hope I made all the electrical connections behind the dash. I give this job a 2 adderall and 12 pack rating. TJ dashes are the devil to take out.

Edit: Well against my better judgement I didn't change the heater core while I was in there and wouldn't you know it, it's now leaking like hell. Yay for taking the dash out again.
 

Attachments

  • 20220430_162832.jpg
    20220430_162832.jpg
    118.1 KB · Views: 29
Last edited:

BNielsen

Member
Joined
Sep 21, 2021
Location
Granite Quarry
Yesterday I got it back from the mechanic's shop after almost a week. That sucked, need to start doing more myself; washed it today and took it over to a friend's shop to get the airbags in and knock out some last minute prep for my camping trip down to Mrytle next week, first time taking the truck on a trip with a trailer but I'm excited!
 

Attachments

  • PXL_20220430_171035048.jpg
    PXL_20220430_171035048.jpg
    302.1 KB · Views: 29
  • PXL_20220430_224140173.jpg
    PXL_20220430_224140173.jpg
    148.2 KB · Views: 33
  • PXL_20220430_224151226.jpg
    PXL_20220430_224151226.jpg
    135.4 KB · Views: 28

BNielsen

Member
Joined
Sep 21, 2021
Location
Granite Quarry
More wrenching; nothing like working on your tow pig two days before you leave for a trip.
New alternator; I swapped to an alt off an LS engine, better design than the factory one and a higher output.

Fighting with a brake controller issue now; but I think I've discovered the issue. Broken ground at the hitch, Tekonsha P3s are super nice, but damn are they sensitive.
 

Attachments

  • PXL_20220502_211746049.jpg
    PXL_20220502_211746049.jpg
    185.2 KB · Views: 27
  • PXL_20220502_211755217.jpg
    PXL_20220502_211755217.jpg
    202.1 KB · Views: 26
  • PXL_20220502_222041944.jpg
    PXL_20220502_222041944.jpg
    179.1 KB · Views: 26

Black Bear

Well-Known Member
Moderator
Joined
Mar 21, 2005
Location
Raleigh, NC
Despite several times draining the water, drying it out, adjusting the vents, etc, the passenger headlight on my truck kept getting condensation (to put it mildly) in it. Well a month or two ago I got a message on the dash of a turn signal being out and the super fast flash. The turn signals were still working, except for one led bulb in the turn signal strip. Still functional, but super annoying, and also not replaceable. So finally got around to ordering new assemblies and installed them today.

View attachment 371719
View attachment 371718

Duane
Where you pick yours up from? I have the same problem with one of my headlight assembly
 

CLRracer

Mopar Nut
Joined
Mar 20, 2005
Location
Archer Lodge
Where you pick yours up from? I have the same problem with one of my headlight assembly

I got them from CARiD, they're the CG brand. They were the cheapest OEM style projector replacements I could find, but they seem like solid units. I've never had any complaints about the light output from the OEM lights, so I didn't feel the need to upgrade to something different.

Duane
 

BNielsen

Member
Joined
Sep 21, 2021
Location
Granite Quarry
Well today was one for the shitter.

Made it to Mrytle, truck still acted up with heavy misfiring under throttle; I'm suspecting the coil or ICM. Luckily I packed the new ones so I'll replace them some time this weekend.

You prep for things and then you get hit with everything coming out of left field. I expected the truck to act up, but I didn't expect it to start leaking gear oil out of the rear end, don't know if it's pinion seal or possibly a wheel seal. Didn't expect my shitter tube to almost fly out of the camper, and I REALLY didn't expect to break a leaf spring. I guess I hit a bump at the right angle, from the looks of it, it's been broken for a while.

So tomorrow it's off to the camper dealer to try and scare up a new leaf pack, the camper's on blocks for now, I just hope I can everything remedied.
 

Attachments

  • PXL_20220505_203210294.jpg
    PXL_20220505_203210294.jpg
    144.1 KB · Views: 53

BNielsen

Member
Joined
Sep 21, 2021
Location
Granite Quarry
Well today was one for the shitter.

Made it to Mrytle, truck still acted up with heavy misfiring under throttle; I'm suspecting the coil or ICM. Luckily I packed the new ones so I'll replace them some time this weekend.

You prep for things and then you get hit with everything coming out of left field. I expected the truck to act up, but I didn't expect it to start leaking gear oil out of the rear end, don't know if it's pinion seal or possibly a wheel seal. Didn't expect my shitter tube to almost fly out of the camper, and I REALLY didn't expect to break a leaf spring. I guess I hit a bump at the right angle, from the looks of it, it's been broken for a while.

So tomorrow it's off to the camper dealer to try and scare up a new leaf pack, the camper's on blocks for now, I just hope I can everything remedied.
Figured I better update this, Camping World didn't have the leaf. But I was directed to a metal fabrication shop in MB; Owen's Metal & Fabrication.
I walked in with a broken leaf and walked out with a brand new leaf and two new bolts in less than 10 minutes! All for $65!
Hauled ass back to the camp grounds, and got everything back together. I watched my mirrors like a hawk and avoided every pothole I could on the drive back. Truck still acted up, but I made it home. Going to try and fix a few things to see if anything helps the truck pull the camper better; it pulls like a freight train when it's cold, but after about 30-45 minutes of driving and everything getting heated up it falls on it's face.
 

BNielsen

Member
Joined
Sep 21, 2021
Location
Granite Quarry
No help on the truck but I’d avoid CW like the plague. 99% of your axle and suspension issue can be solved by hitting the local trailer store and avoid the “camper people ignorance up charge”.

Just my .02. YMMV.
That was my thinking, but it was Mrytle Beach, and from what I could bring up on Google the "closest" trailer shop was 45 minutes one way. I knew it wouldn't be cheap from Glamping World, but I was in a hurry to get everything back together

From what the dude at the metal shop said he does a lot of trailer/camper springs. Hell of a good deal either way.
 

CasterTroy

Motarded
Joined
Mar 21, 2005
Location
Wallburg
That Bimmerworld tape hides expensive things. Bless you.
BMW use to be $1000 cover charge for dealer/certified mechanic shop. But damn NOW? likely $2500 cover charge at the door for anything
 

Black Bear

Well-Known Member
Moderator
Joined
Mar 21, 2005
Location
Raleigh, NC
I got them from CARiD, they're the CG brand. They were the cheapest OEM style projector replacements I could find, but they seem like solid units. I've never had any complaints about the light output from the OEM lights, so I didn't feel the need to upgrade to something different.

Duane


Thanks! Mine came in today. It's nice not to have a foggy headlight
 
Top